How to Connect to BHSU-Guest

Issue/Question

How do I connect to the Guest Wi-Fi on campus?
How do I connect to BHSU-Guest?
How do Guest Connect to the Wi-Fi?

Environment

Spearfish and Rapid City Campus

Wireless Networks:

  • BHSU-Guest  

Device Operating Systems:

  • Windows OS
  • MacOS
  • iOS
  • iPadOS 
  • Android
  • ChromeBook

Gaming and/or Systems:

  • PlayStation 4 & 5
  • Xbox One & Series X
  • Nintendo Switch 
  • Roku and/or Smart TVs
  • Personal Printers

Cause

I'm a guest on campus and would like to connect to the WiFi.
I got a new device.  

Resolution

BHSU-Guest is a Wi-Fi network available on campus that anyone can connect to. 

If you are Student from another University that is visiting our Campus, you may be able to connect to the eduroam network.
Eduroam is only available for Students enrolled at participating Universities. To check if your University is participating, please go to: eduroam's "Where" section of their Website, and navigate through your country/state to find your School.

***Important Note for BHSU Students staying in the Residence Halls***

Some Devices will be unable to connect to BHSU-Secure and eduroam, and will require that you use the BHSU-Guest network.


To get the Ethernet port activated with-in your room, please fill out the Residence Hall Network service request form

BHSU-Guest - How to Connect Guides:

If you have already created a Guest Account in the past, please click into the Re-activate your BHSU-Guest account guide below. 


+ Set up a BHSU-Guest Account  

  1. Select BHSU-Guest at the network selection screen
  2. Open a web browser – i.e. Safari, Chrome, Internet Explorer, etc., and if you are not directed to the SafeConnect login screen, go to an off-campus website like https://sd.gov/ and you will be redirected shortly
  3. Once you are on our SafeConnect website, you will be prompted to log in

    • Click "Request a Guest Account.
    • Fill in your email address, name, and cell phone number, and click “Continue”

  1. Check your cell phone and/or your email to get the access code.

  1. Click “Continue” on the device to which you are requesting access.
  2. Input your username and the password from the email or text into the field provided and click “Continue.”
  3. You are now connected to the network for 30 Days

+ Sign into BHSU-Guest 

  1. Select BHSU-Guest at the network selection screen
  2. Open a web browser – i.e. Safari, Chrome, Internet Explorer, etc., and if you are not directed to the SafeConnect login screen, go to an off-campus website like https://sd.gov/ and you will be redirected shortly
  3. Use the following Sign in Information: 
    1. User Name: 
      1. Use the user name that was emailed/texted to you
    2. Password:
      1. Use the password that was emailed/texted to you
         
  4. Click on Sign In

After creating a Guest Account, your account will be able to connect to BHSU-Guest for a 30 day time period before needing to be re-activated.

To reactivate your BHSU-Guest account, please click into the guide below: 


+ Re-Activate your BHSU-Guest Account 

  1. Select BHSU-Guest at the network selection screen
  2. Open a web browser – i.e. Safari, Chrome, Edge, etc., and if you are not directed to the SafeConnect login screen, go to an off-campus website like https://sd.gov/ and you will be redirected shortly
  3. Once you are on our SafeConnect website, you will be prompted to log in
  4. Click on Click Here and you'll be re-directed to a page requesting your information.  

If you are running into issues when trying to connect to BHSU-Guest, please submit a ticket or visit the BHSU Help Desk for more assistance.
The Spearfish Help Desk is Located on the First floor of the Library by the Reddish-Orange Wall. 
The Rapid City Help Desk is Located on the First floor, Room 121. 

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