Ethernet Port Activation

Issue/Question

The Ethernet port in my dorm room doesn’t work 

Environment

  • Dorms 
  • Campus Apartments 
  • Ethernet / wired connection 
  • Wall ports 

Cause

  • Hardware issue on a personal device 
  • Bad Ethernet cable 
  • Disabled port 

Resolution

  1. Please ensure that your device has the correct hardware needed for Ethernet  
  2. Try at least two different Cat5 or Cat6 Ethernet cables 
  3. If you are still unable to connect, the port may be disabled. Submit a service request and In the ticket, please specify: 
    1. Resident Hall or Campus Apartment you are in 
    2. Room number Port number (if applicable) 
    3. Device type (gaming console, laptop, desktop, etc.; wireless routers are not allowed)
    4. Any other relevant details (ex. The port worked yesterday but now it doesn’t)
Please submit a ticket if you need further assistance
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Related Services / Offerings (1)

Report an issue or request assistance with connectivity to the campus wireless (Wi-Fi) signal.