Issue/Question
How do get Transact eAccounts?
How do I set up Buzz Card Mobile?
Environment
Cause
Student, Faculty, or Staff member looking to set up Buzz Card Mobile.
Resolution
Before getting Buzz Card Mobile, you will need to submit a photo for your Buzz Card.
If you have not already done so, please check your email for instructions:
- Search your email inbox for subject line: "Submit Your Photo For Your Student ID (Buzz Card)"
- Check your junk email folder if you don't see it
- If you can't find it, please contact BuzzCard@BHSU.edu
Once your Photo is approved, you will receive an approval email with these next steps.
Install the Transact eAccounts App found on the Apple App Store or the Google Play Store.
+ Click Here to see a list of compatible devices
- iPhone
- iPhone SE, iPhone 6, iPhone 6 Plus or later
- iOS 12 or later
- Apple Watch
- Apple Watch Series 1 or later
- WatchOS 5 or later
- Galaxy Watch
- Apple ID
- Signed into iCloud
- If two devices are used, both must be signed into same iCloud account
- Android Phone
- Version 6.0 or later
- NFC-enabled device capable of supporting Google Wallet or Samsung Wallet
- Samsung (US Versions with Android S or later)
- Galaxy S Series – S20 or later
- Galaxy Note Series – Note20
- Galaxy Z Series – Z Flip 5G, Fold 5G, Z Flip 2, Fold 2 or later
- Galaxy A Series – A53
- Note: This feature may not work on:
- S20 FE 5G models
- Galaxy A71 5G
- Galaxy Fold
- Galaxy Note10, Note10+, Note10+ 5G
- Galaxy S10, S10+, S10e, S10 5G, S10 Lite
- Galaxy Z Flip
- International versions of all devices
- Find Device Info
- Go to Settings > About phone > Product Name
- eAccounts App
Apple ID
Signed into iCloud. If two devices are used, both must be signed into same iCloud account.
Android Phone
Version 6.0 or later; NFC enabled device capable of supporting Google Waller or Samsung Wallet.
Samsung
The United States versions of the following eSE enabled devices with Android S or later OS:
Galaxy S Series – S20 or later
Galaxy Note Series – Note20
Galaxy Z Series – Z Flip 5G, Fold 5G, Z Flip 2, and Fold 2 or later
Galaxy A Series – A53
*Note: This feature may not work on S20 FE 5G models, Galaxy A71 5G, Galaxy Fold, Galaxy Note10, Galaxy Note10+, Galaxy Note10+ 5G, Galaxy S10, Galaxy S10 5G, Galaxy S10 Lite, Galaxy S10+, Galaxy S10e, Galaxy Z Flip and on international versions of all devices.
You can find your device information by going to Settings > About phone > Product Name
eAccounts App
Download from Apple App Store or Google Play Store by searching for "Transact eAccounts" (red icon)